Verity Service for Excel, Degraded Performance for Canada, Europe and United States users

Incident Report for Caseware Cloud

Resolved

The issue affecting Verity Service in the Canada, Europe, and United States regions has been resolved.

The root cause was identified, and corrective actions were successfully implemented. Service has returned to normal operation, and our teams have confirmed stability across the affected regions.

We will continue to monitor the environment to ensure service remains healthy.

We apologize for any inconvenience and appreciate your patience throughout this incident.
Posted Jul 30, 2026 - 15:40 UTC

Monitoring

We are experiencing a Degraded Performance impacting Verity Service in Canada, Europe and United States region(s).

The root cause was identified, and corrective actions have been successfully implemented. Service has returned to normal operation, and we continue to monitor the environment to ensure stability.
An update will be provided within the hour.

We apologize for any inconvenience and appreciate your patience.
Posted Jul 30, 2026 - 15:19 UTC

Identified

We are experiencing a Degraded Performance impacting Verity Service in Canada, Europe and United States region(s).

The root cause has been identified, and our teams are actively working on remediation efforts to restore service stability.

An update will be provided within the hour.

We apologize for any inconvenience and appreciate your patience.
Posted Jul 30, 2026 - 15:04 UTC

Investigating

We are experiencing a Degraded Performance impacting Verity Service for Excel in Canada, Europe and United States region(s). Our teams are actively investigating the issue, identifying the root cause, and implementing the necessary corrective actions. An update will be provided within the hour.
Posted Jul 30, 2026 - 14:04 UTC
This incident affected: Canada (CA) (Data Analytics Platform), United States (US) (Data Analytics Platform), and Europe (EU) (Data Analytics Platform).