Cloud-based Engagement Solutions, Partial Outage for United States users

Incident Report for Caseware Cloud

Resolved

The source of the Cloud-based Engagement Solutions Partial Outage for the DAS product affecting some forms has been resumed successfully - Incident Resolved.
We apologize for any inconvenience.
Posted Feb 26, 2025 - 01:42 UTC

Monitoring

The source of the Cloud-based Engagement Solutions Partial Outage for the DAS product which affected some forms has resumed normal activity.
We are actively monitoring our systems to ensure that there are no residual issues. We will continue to provide updates as necessary.
Posted Feb 26, 2025 - 01:36 UTC

Update

The source of the Cloud-based Engagement Solutions Partial Outage for DAS product affecting some forms has been identified and still working on the potential solution that we found.
Posted Feb 26, 2025 - 00:42 UTC

Update

The source of the Cloud-based Engagement Solutions Partial Outage for DAS product affecting some forms has been identified and still working on the potential solution that we found.
Posted Feb 25, 2025 - 23:41 UTC

Update

The source of the Cloud-based Engagement Solutions Partial Outage for DAS product affecting some forms has been identified and still working on the potential solution that we found.
Posted Feb 25, 2025 - 22:45 UTC

Update

The source of the Cloud-based Engagement Solutions Partial Outage for DAS product affecting some forms has been identified and we have found a potential solution.
Posted Feb 25, 2025 - 21:39 UTC

Identified

The source of the Cloud-based Engagement Solutions Partial Outage for DAS product affecting some forms has been identified and we have found a potential solution.
Posted Feb 25, 2025 - 20:41 UTC

Investigating

There is an ongoing outage with our DAS product affecting the following forms. Based on our initial assessment, it may be linked to recent updates to the risk library. We are continuing to investigate. The following documents are known to be affected:
RA-1 --> Accounts are not showing up
RA-3 --> Standard response not loading
IC-1 --> Risk to Subprocess mapping issues

There is no evidence at this time suggesting data loss. The data is hidden and should re-appear when the issue is resolved.
Posted Feb 25, 2025 - 20:04 UTC
This incident affected: United States (US) (Cloud-based Engagement Solutions).