Caseware Cloud Service Degraded Performance for Users in US
Incident Report for Caseware Cloud
Resolved
The United states Caseware Cloud Service has been restored to normal operation. You should now be able to work with Caseware Cloud normally and without incident.
We thank you for your patience and understanding during the service disruption.
Posted Feb 28, 2024 - 19:58 UTC
Monitoring
Caseware Cloud Service has resumed normal activity in the United States region.
We are actively monitoring our systems to ensure that there are no residual issues. We will continue to provide updates as necessary.
Posted Feb 28, 2024 - 18:55 UTC
Update
We continue to investigate the service disruption to our Caseware Cloud Service in the US region. No additional information is available at this time but we will continue to keep you informed as new information becomes available.
Posted Feb 28, 2024 - 18:29 UTC
Investigating
We are currently experiencing a service disruption of our Caseware Cloud Service in the US region. We are working to identify the root cause and determine the necessary corrective actions.
Until we are able to resolve this issue users might experience slow performance while working within Caseware Cloud.
An update will be provided within the hour.
Posted Feb 28, 2024 - 17:25 UTC
This incident affected: United States (US) (Caseware Cloud Service).