Cloud-based Engagement Solutions - Cloud Connector, Partial Outage, All Regions

Incident Report for Caseware Cloud

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 00:05 UTC

Monitoring

Cloud-based Engagement Solutions in all regions have resumed normal activity.
We are continuing to monitor our systems to ensure that there are no residual issues. We will continue to provide updates as necessary.
Posted Oct 29, 2025 - 21:41 UTC

Identified

The source of the partial outage for Caseware Cloud Connector in all regions has been identified,
Microsoft initiated the deployment and actively working.
An update will be provided within the hour.
We apologize for any inconvenience.
Posted Oct 29, 2025 - 20:02 UTC

Investigating

We are experiencing a partial outage for Caseware Cloud Connector in all regions.
Initial investigation indicates that these disruptions are related to an ongoing Microsoft outage, which is impacting connectivity and availability for Cloud Connector.

Our technical teams are actively monitoring the Microsoft incident and further updates will be provided as it becomes available.

We apologize for any inconvenience.
Posted Oct 29, 2025 - 15:45 UTC
This incident affected: United States (US) (Cloud-based Engagement Solutions), Asia Pacific (AP) (Cloud-based Engagement Solutions), Canada (CA) (Cloud-based Engagement Solutions), and Europe (EU) (Cloud-based Engagement Solutions).