Cloud-based Engagement Solutions, Degraded Performance for United States and Asia Pacific users

Incident Report for Caseware Cloud

Resolved

Cloud Connectors in Cloud-based Engagement Solutions monitoring has resumed successfully - Incident Resolved.
We apologize for any inconvenience.
Posted Apr 13, 2026 - 18:11 UTC

Monitoring

Cloud Connectors in Cloud-based Engagement Solutions has resumed normal activity.
We are actively monitoring our systems to ensure that there are no residual issues.
Posted Apr 13, 2026 - 17:46 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 13, 2026 - 17:09 UTC

Identified

Our engineering teams continue to work toward implementing a potential solution.
We will provide further updates as progress continues or once a resolution is available.
Posted Apr 13, 2026 - 16:16 UTC

Update

Our teams are working to identify the root cause and determine the necessary corrective actions.
An update will be provided within the hour.
We apologize for any inconvenience.
Posted Apr 13, 2026 - 15:14 UTC

Investigating

We are experiencing a Degraded Performance of Cloud Connectors for our Cloud-based Engagement Solutions affecting some products in the United States and Asia Pacific region(s).

Our teams are working to identify the root cause and determine the necessary corrective actions.
An update will be provided within the hour.
We apologize for any inconvenience.
Posted Apr 13, 2026 - 14:49 UTC
This incident affected: United States (US) (Cloud-based Engagement Solutions) and Asia Pacific (AP) (Cloud-based Engagement Solutions).