Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 07, 2024 - 02:00 UTC
Scheduled
Please note that we will perform emergency maintenance to the Cloud-based Engagement Solutions Server for the Canada and United States region(s), Production Environment.
Expected Impact: Cloud-based Engagement Solutions will be intermittently unavailable during the maintenance window. All other services will be available.
Action Required: We recommend that you save your work and log out of Caseware Cloud prior to the start of the maintenance period.
Posted Nov 06, 2024 - 22:13 UTC
This scheduled maintenance affected: United States (US) (Cloud-based Engagement Solutions) and Canada (CA) (Cloud-based Engagement Solutions).