SE Platform Degraded Performance for Users in CA & US
Incident Report for Caseware Cloud
Resolved
The CA & US SE Platform has been restored to normal operation.
We thank you for your patience and understanding during the service disruption.
Posted Feb 20, 2020 - 16:53 UTC
Investigating
We are currently experiencing a service disruption to our Cloud Engagement (SE) Platform relating to the "Download Reference Copy" and Print to PDF features in the CA & US regions. We are working to identify the root cause and determine the necessary corrective actions.
An update will be provided within the hour.
Posted Feb 20, 2020 - 16:33 UTC
This incident affected: United States (US) (SE Platform).